How to troubleshoot errors when connecting to a MYOB source

Issue


Users may encounter one of the following errors when attempting to load data from a MYOB file in an Active Ledger dataset or into Active Workpapers:

1- 'Your my.myob account or the supplied credentials do not allow you to access this file.'


2- 'Error refreshing data from MYOB into 2023 Actual. Your my.myob account or the supplied credentials do not allow you to access this file.'   



Cause


These errors could stem from any of the following reasons:


1- The user is logged into app.myob.com on the same browser with a MYOB login that lacks access to that specific MYOB file

2- The user's my.myob email is not associated with a UserId in that particular MYOB file

3- The user's access is restricted or insufficient, limiting API access to the file due to assigned roles

4- The user's UserId in MYOB might be inactive
5- The MYOB file needs updating
6- The offline login credentials used to connect to the MYOB file are incorrect.


Resolution


To resolve this issue, please follow these steps:


1. Log out of the Active platform and close any browser tabs using Active

2. Visit app.myob.com, log out, and then log back in using the correct credentials. Ensure that you can open the relevant MYOB file fully (perform any updates on the myob file if prompted)

3. Log back into your active platform

4. Navigate to Settings and Tools (of your Ledger dataset and/or Active Workpapers binder) > Manage Sources > Click on 'Update Connection.' Log in to the MYOB login screen to refresh the connection

5. Please ensure the MYOB (offline) user ID and password entered on the source screen are correct. Then, finally, click save source or load data, whichever is applicable.

Did you find it helpful? Yes No

Send feedback
Sorry we couldn't be helpful. Help us improve this article with your feedback.